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Benefits of FaxPress and GoldMine Integration
FaxPress network fax servers support GoldMine 3.x through 6.x. 

FaxPress integration with Goldmine enables:

• broadcast of customized faxes to a GoldMine contact list, with full GoldMine fax merge support.

• easy broadcasting of fixed documents to GoldMine contacts 

• quick faxing to a GoldMine contact without needing entry of destination fax number, name etc 

Installing the FaxPress GoldMine link provides convenient new options in Word and in GoldMine. After the 
installation, your Word documents will include a GoldMine option in the menu bar, and a GoldMine Contact 
via Castelle FaxPress option under File>Send to.

In the GoldMine program, the Fax via FaxPress option will be added into the File menu. This option 
launches the FaxPress Send Fax dialog box and automatically connects it to your Goldmine Contacts List.

Preparing for the Installation
Before you begin the GoldMine to FaxPress Link installation, confirm the following:

1. Confirm FaxPress client software is installed. To use a GoldMine/FaxPress connection, you must be 
running FaxPress 6.0 or above client software.

2. Make sure all open applications are closed before beginning the install. 

3. Confirm the Microsoft Macro Security settings are set to Medium or Low, by opening a Word docu-
ment and going to Tools> Macro>Security..
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If your security option is set to High make sure you change it to Medium or Low.

4. Make sure the Microsoft dBase driver for ODBC (Open Database Connectivity) is installed and made 
available as a data source. 32-bit ODBC must also be installed. If the dBase driver is not enabled, and 
ODBC is not already installed and operational, please see Installing 32 Bit ODBC and DAO on page 
15.

5. Open a Word doc, and go to Tools>Templates and Add Ins to confirm that only gmlink.dot is listed 
under Global Templates and Add-ins. 

Frequently, other macros will need to be removed from Templates and Add-ins, like Adobe Acrobat Reader 
or Writer templates. You will also need to delete these using Windows Explorer in addition to removing them. 
The GMLink.dot file should also be removed, manually, as described below.
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Preparing for the Installation
Installing the Goldmine to FaxPress Link
The Goldmine to FaxPress Link creates the Fax via FaxPress option in the Goldmine File menu. This option 
launches the FaxPress Send Fax dialog box and automatically connects it to your Goldmine Contacts List.

The GoldMine to FaxPress Link installation must not be done on top of an existing GoldMine Link to Word. 
Any currently installed GoldMine Link to Word must be removed before the GoldMine to FaxPress 
Link installation. The FaxPress Goldmine link will not be installed if the existing GoldMine Link to Word 
is not removed, but there will be no error message notifying you the link installation was not successful.. 

To remove any existing GoldMine Link to Word, follow these steps:

1. Run the gmlinkinstaller.exe file, then follow the prompts to remove the currently installed GoldMine 
Link to Word. 

2. Confirm that the existing GoldMine link to Word has been removed by making sure that the Gold-
Mine dropdown menu no longer appears in your Word documents. If you can still see the Goldmine 
dropdown menu from an open Word document, uninstall the link from the GoldMine dropdown menu.

3. Do a search (Start>Find Files or Folders) for the files GMlink.dot and Normal.dot and remove them.

To install FaxPress/GoldMine link, follow these steps:

1. Exit all other applications.

2. Start GoldMine.

3. Go to Start>FaxPress>GoldMine>Install GoldMine 6.0.

4. If a warning about macros appears, choose Enable Macros.

5. Next click on Install.
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6. Next click on OK

7. Next click on OK.

8. Next click on Configure.
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Preparing for the Installation
9. Next chose a FaxPress server and put in a FaxPress user name and password, then click on Login.

10. Next you must click on Save Preferences

11. Click OK.

The GoldMine link should appear under MS-Word tool  bar.
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Installation Tips

If you are having issues with the FaxPress GoldMine Link support, please check first whether you can install 
the GoldMine Link without FaxPress involved. 

If you are having problems with the GoldMine Link, check the following pre requisites first, then manually 
uninstall and reinstall the GoldMine Link to make sure it is working without FaxPress involved.

If you’re experiencing some issues with your GoldMine link install, check these

• Some Antivirus Software may be running and not allowing the macro to be installed. Always shut 
down your AntiVirus software.

• If you are doing a manual re-install, try getting a fresh link copy from Castelle’s download site as 
your copy of the link may be corrupt.

• Find out whether ot not Local Admin Rights are required for this procedure. Right click on My Com-
puter, then select Manage, then Local Users and Groups to confirm.

• Make sure a local security policy isn’t blocking you from installing (Start >Settings >Control Panel 
>Admin Tools >Local Security Policy). 

Uninstalling the Goldmine to FaxPress Link
To uninstall the Goldmine to FaxPress link:

1. Go to Start>FaxPress>GoldMine>Install GoldMine 6.0

Note: If a warning about macros appears, choose Enable Macros.

2. Click the Uninstall GoldMine to FaxPress Menu button to remove the FaxPress/GoldMine link.

3. Close the installation document and restart GoldMine.

The connection between FaxPress and GoldMine has now been broken.

Faxing with the GoldMine/FaxPress Connection
There are several ways to fax with the link between FaxPress and Goldmine. From within GoldMine, users 
can send faxes through Faxmain or can use the merge mechanism provided by GoldMine. Additionally, 
automated processes can be set up.

Faxing with the FaxPress Link
To Fax from Goldmine via FaxPress link:

1. Open Goldmine and activate the contacts or groups that you want to send a fax.
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Faxing with the GoldMine/FaxPress Connection
2. Select the Fax via FaxPress... from the File pull down menu in your Goldmine menu bar. The Gold-
mine Record Range screen will be displayed.

3. Select Current Contact to send the fax to the activated contact or All Contacts to send to all. 

Note: If you have not activated a contact or group this fax will be sent to all contacts in the database. 

4. If you have not activated automatic login to Faxmain, the FaxPress Login screen will be displayed. 
Fill in your user name and password. 

The Send Fax dialog box will pop up with the recipient information from the GoldMine database already 
embedded.

5. Complete the dialog box by adding a message, choosing a cover page or adding any attachments.

6. Once the dialog box is filled out, click on Send Fax.

The fax will be sent to the contact or list of contacts specified. 
9
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Entries will be added to each contacts history list indicating that the fax has been sent, subject of the fax, and 
list of any attachments to the fax. 

You will be able to obtain status information about the fax transmission by checking the Outgoing Faxes or 
Notices list in FaxMain. See Chapter 18, "Notices and Alerts".

Faxing Merged Forms
With the merge feature, you can add specific information to documents that you use frequently. Merging 
GoldMine data and a template document will allow you to create customized faxes specifically made for that 
contact. 

1. Select the Merge Forms from the File pull down menu in your Goldmine menu bar.

2. Choose a document/form to merge. Any template may be used from any user in the Forms of User 
combo box as long as the Documents option is selected. 

3. Specify record selection from the following options:

• This Contact —will fax to the currently active contact record, 

• All Contacts— will fax to the currently active filtered list or group of contacts

• Forward to Last— will fax to all contacts starting from the current active record, taking all filters 
and groups into account. 

• Primary— will only fax to the primary contact of the record and selecting 
10



Creating Templates
• Additional— will fax to the additional contacts of the same record. 

 If both Primary and Additional are selected, then faxes will be generated for the Primary and Additional 
contacts. 

4. Click on FAX at the bottom of the screen.

The FaxPress/GoldMine connection software will automatically launch MS-Word, merge information into 
the document and then send the document to all the contacts specified. After the fax has been submitted to 
the FaxPress, a message appears notifying the user that the fax has been sent successfully.

Entries will be added to each contacts history list indicating that the fax has been sent and the name of the 
merged document. 

Merging from MS Word
Faxing to a Single Contact from MS Word

The user can fax the current active MS Word document to the current contact in GoldMine. The document 
may or may not be a GoldMine template.

1. Make sure that the GoldMine contact who is to receive the fax is the current contact in GoldMine. 
This means that the contact record is on top and is being viewed.

2. In Word, select Send to Contact via Fax… from the File pull down menu.

This will fax the document to the current contact using the name, company, and fax information. The 
FaxPress login dialog box may appear depending on the settings that were set using the FaxPress Login 
menu.

Creating Templates
You can create a GoldMine template, insert information into it from a GoldMine contact database, and send 
the merged documents as faxes.

To create a template, follow the steps below. For more information about creating templates, see the 
appropriate section in the GoldMine manual.

1. Create a new Microsoft Word document and include all the text and graphics that will stay the same 
for each version of the merged document.
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2. Place your cursor at the desired location and then, from the MS-Word Insert menu, select GoldMine 
Field... The Insert GoldMine DDE Field dialog will appear.

3. Select the desired field names from the list and then press the OK button. The selected fields will be 
placed into the template document.

4. Repeat insertions as needed to add additional Goldmine fields.

5. Save the template by selecting File / SaveAs GoldMine Template....

If the document has not been previously saved, you will be prompted for a document title file name to save 
it. This will make an entry in the GoldMine Merge Forms window.

6. The template document you just created will now be available from your list of merge forms.

To verify that this operation was successful, select Merge Forms... from your GoldMine File menu to bring 
up the Merge Forms dialog:

The forms will be listed number the name of the current Goldmine user displayed in the Forms of User 
scroll down list.
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Updating GoldMine Templates
7. Selecting the document and clicking the Properties button will bring up the properties of the docu-
ment:

• Form Name field should contain the title of the document

• Template Filename field should contain the full path to the Word document 

• App Identifier field should contain “Word.Document.8”

• DDE Command field should contain “[GoldMineLink()].” If these settings are not correct, a Gold-
Mine merge using this template will not work.

Updating GoldMine Templates
If you change a GoldMine template document, you must also update the GoldMine form record for the 
template.

A form record contains a list of all the merge fields that are in the template, so that GoldMine can export a 
dBase file containing the correct fields for merging purposes.

If a document is changed and the form record is not updated, fax merge may not work correctly because the 
exported file may or may not contain the necessary fields that are required for the merge.

There are several ways to update the form record corresponding to the template.

Updating Templates from within MS Word
1. From within Word, open the template.

2. Make the changes: adding and/or deleting GoldMine fields as necessary.

3. From the File menu, select Update GoldMine Template....

This will update the form record automatically and save the changes to the template.

Updating Templates from within GoldMine
1. From the GoldMine File menu, select Merge Forms... to bring up the Merge Forms dialog.
13
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2. Select the template that needs to be updated and then click on the Properties button to bring up the 
Form Template Properties dialog.

3. Click on the Edit button. This will launch Word with the template for editing.

4. Make the changes: adding and/or deleting GoldMine fields as necessary.

5. From the File menu, select Update GoldMine Template.... This will update the form record automati-
cally and save the changes to the template.

Configuring FaxPress Login
To automate faxing, you can configure the login parameters that will be used to send the faxes to FaxPress.

To configure FaxPress Login, do the following.

1. From Word, select the Tools menu and then select Configure FaxPress Login.... This will bring up 
the FaxPress Server Login dialog box.

2. Specify the Server name, User Name and Password. You may need to check with your system 
administrator to determine these items.

3. Check the Use These Settings Next Time check box to retain these settings.

4. Click on the Login button

The next time you fax something from within GoldMine, these server settings will be applied.

Automated Faxing
You can also send faxes to GoldMine contacts using GoldMine Automated Processes, if you have previously 
set up the process to fax a document using the Print Form option.

When a fax is sent using Automated Faxing, an entry is made to the contact history.

For more information about Automated Faxing, see your GoldMine manual.
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Installing 32 Bit ODBC and DAO
Installing 32 Bit ODBC and DAO
Open Database Connectivity (ODBC) is an open standard application programming interface (API) for 
accessing a database. By using ODBC statements in a program, you can access files in a number of different 
databases, including Access, dBase, DB2, Excel, and Text. In addition to the ODBC software, a separate 
module or driver is needed for each database to be accessed.

Installing ODBC
ODBC is already installed on Windows Me, Windows XP, Windows 2000 Professional and 2000 server, and 
may already be installed on your workstation or server. To determine whether or not ODBC is already 
installed, search for the file "odbc32.dll" or "odbc*.*" If you do not have a 32 Bit ODBC installed on your 
machine, you can install it from your FaxPress CD.

To install a 32 Bit ODBC, click on MDAC_TYP.EXE. The 32 Bit ODBC will be installed on your desktop.

Microsoft's Data Access Objects (DAO) 3.6
DAO  (Data Access Objects)  is an application program interface (API) available with Microsoft's Visual 
Basic that lets a programmer request access to a Microsoft Access database DAO contains the library files for 
Microsoft's Jet database engine, which is used to access Microsoft Access databases. 

DAO is already installed on Windows Me, Windows XP, Windows 2000 Professional and 2000 server, and 
may already be installed on your workstation or server.  To determine whether or not DAO is already installed, 
search for the file "dao360.dll" or "DAO*. *" 

DAO 3.6 is provided on the FaxPress installation CD, in the Microsoft folder in the ODBC installation folder. 
You will only need to install the ODBC if it doesn't already exist.

Follow these instructions for the installation of the ODBC, DAO drivers & Jet 4.0.

Windows 98 NT 4.0

Run Mdac_typ25.exe, this is provided on the FaxPress installation CD in the \Microsoft\odbc installation 
directory 

For NT 4.0 prior to SP3 run Mdac_typ21.exe.

Registering DAO 3.6

Create a directory with the name DAO under System Drive:\Program Files\Common Files\Microsoft Shared 
and copy Dao360.dll to this directory. This .dll is provided on the FaxPress installation CD in the 
\Microsoft\odbc installation directory. 

 In addition, Dao360.dll must be registered as a COM DLL. This can be accomplished by using the 
Regsvr32.EXE utility, e.g. 

RegSvr32 "C:\Program Files\Common Files\Microsoft Shared\DAO\Dao360.dll"
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Installing ODBC Drivers
Check Status
To check that the required ODBC driver is installed, double-check on the ODBC icon and inspect the ODBC 
Data Source Administrator screen. Select the Drivers tab and make sure that the driver corresponding to the 
data source you will be using is available.

Adding a New Data Source Name

If your data source is a dBase file, then the Microsoft dBase driver must be available as a User DSN or a 
System DSN. To check if the dBase driver is available as a data source, do the following.

1. Select the User DSN or System DSN tab. Two columns,  a Name column and a Driver column, are 
displayed.
16



Installing 32 Bit ODBC and DAO
2. Check to see if the .dbf driver is there.

Look through the list and make sure that the Driver column contains the Microsoft dBase Driver(*.dbf). 
The corresponding Name does not matter.

If the driver is not present, look in the other tab (in the above case, check the System DSN tab).

Where the dBase driver is located does not matter as long as it is present in one of these locations. The only 
difference is that the User DSN can only be seen by the current user that is logged into the workstation, 
while the System DSN can be seen by all users who login to the same workstation.

3. Install the dBase driver if needed.

If you need the dBase driver, you can add it by doing the following.

a. Click on Add.

b. Select either the User DSN or System DSN tab and click on the Add button. The Create New Data 
Source dialog will be displayed.

The list of available drivers depends on the drivers that are currently installed on the system.

c. Select the dBase driver.
d. Select the Microsoft dBase Driver (*.dbf).
17
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4. Click on Finish.

Click on the Finish button. The ODBC dBase Setup dialog will appear.

5. Enter a Name and, optionally, a Description.

Data Source Name— Enter a name for Data Source Name field. This is required.

Description— Enter a description for the Description field. This is optional.

Version— Make sure that the Version corresponds to the version of the dBase file or higher.

6. When done, click OK.
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